Cuadro de diálogo Inicio de sesión en Microsoft SQL Server

El proveedor de OLE DB de Microsoft® SQL Server™ muestra el cuadro de diálogo Inicio de sesión en Microsoft SQL Server cuando llama a una conexión OLE DB sin especificar la información suficiente para que el controlador se conecte a SQL Server.

Cuando se muestra por primera vez este cuadro de diálogo, sólo presenta lo siguiente:

Cuadro Servidor.

Casilla de verificación Usar conexión de confianza.

Cuadro Id. de inicio de sesión.

Cuadro Contraseña.

Botones Aceptar, Cancelar, Ayuda y Opciones.

Si hace clic en el botón Opciones, el cuadro de diálogo se expande para mostrar el grupo Opciones:

Cuadro Base de datos

Cuadro Idioma

Cuadro Nombre de la aplicación

Cuadro Id. de estación de trabajo

Cuadro Servidor

Nombre de un servidor de SQL Server en su red. Si selecciona un nombre de servidor de la lista, no necesitará configurarlo. Si escribe un nombre de servidor, debe ser una entrada avanzada en la utilidad Configuración del cliente de SQL o el nombre de la red de un servidor que ejecuta SQL Server.

Puede escribir "(local)" en el cuadro servidor si está utilizando el mismo equipo que SQL Server. En este caso, el usuario se puede conectar a una copia local de SQL Server, incluso cuando ejecute una versión de SQL Server que no funcione en red. Para especificar una instancia de nombre de SQL Server, el nombre del servidor se especifica como ServerName\InstanceName.

Para obtener más información acerca de los nombres de los servidores para diferentes tipos de redes, consulte la documentación de la instalación de SQL Server en los Libros en pantalla de SQL Server.

Casilla de verificación Usar conexión de confianza

Cuando se activa, especifica que el proveedor de SQL Server OLE DB solicita una conexión segura (o fiable) a SQL Server que se ejecuta en Microsoft Windows NT® o Windows® 2000. Al activar esta opción, SQL Server utiliza seguridad integrada de inicio de sesión para establecer las conexiones que utilizan este origen de datos sin tener en cuenta el tipo de seguridad de inicio de sesión del servidor. Se ignora cualquier otro tipo de Id. o contraseña de inicio de sesión. El administrador del sistema de SQL Server debe tener su Id. de inicio de sesión de Microsoft Windows® asociada con un Id. de inicio de sesión de SQL Server.

Si desactiva esta casilla de verificación, SQL Server utiliza la seguridad de inicio de sesión estándar para establecer conexiones con este origen de datos. Debe especificar un Id. de inicio de sesión y una contraseña para todas las peticiones de conexión.

Cuadro Id. de inicio de sesión

Especifica el Id. de inicio de sesión de SQL Server que se va a utilizar para la conexión si no activó Usar conexión de confianza. Si activó Usar conexión de confianza, el cuadro Id. de inicio de sesión está desactivado.

Cuadro Contraseña

Especifica la contraseña del Id. de inicio de sesión de SQL Server para la conexión si no está activada la casilla de verificación Usar conexión de confianza. Si activó Usar conexión de confianza, el cuadro Contraseña está desactivado.

Cuadro Base de datos

Especifica la base de datos predeterminada que se va a utilizar en la conexión. Ésta suplanta a la base de datos predeterminada especificada para el inicio de sesión en el servidor. Si no especifica ninguna base datos, la conexión utilizará la base de datos predeterminada especificada para el inicio de sesión en el servidor.

Cuadro Idioma

Especifica el idioma que se va a utilizar para los mensajes del sistema de SQL Server. Debe tener instalado el idioma en SQL Server. Éste suplanta al idioma predeterminado especificado para el inicio de sesión en el servidor. Si no especifica ningún idioma, la conexión utilizará el idioma predeterminado especificado para el inicio de sesión en el servidor.

Cuadro Nombre de la aplicación

Especifica, de forma opcional, el nombre de la aplicación que se va a almacenar en la columna program_name de la fila correspondiente a esta conexión en master.dbo.sysprocesses.

Cuadro Id. de estación de trabajo

Especifica, de forma opcional, el Id. de la estación de trabajo que se va a almacenar en la columna hostname de la fila correspondiente a esta conexión en master.dbo.sysprocesses.


Copyright y renuncia de Microsoft SQL Server 2000

Este documento, incluidas las aplicaciones de ejemplo que contiene, se proporciona con propósito informativo únicamente y Microsoft no otorga garantías expresas ni implícitas en este documento. La información contenida en este documento, incluidos los ejemplos, las direcciones URL y otras referencias a sitios Web de Internet, está sujeta a modificaciones sin previo aviso. El usuario asume todos los riesgos resultantes del uso de este documento.

El objetivo principal de los ejemplos es ilustrar un concepto o un uso razonable de una instrucción o cláusula determinada. La mayoría de los ejemplos no incluyen todo el código que debería tener un sistema totalmente productivo, puesto que gran parte de la validación de datos comunes y administración de errores se elimina para resaltar un determinado concepto o instrucción. No existe soporte técnico disponible para estos ejemplos o el código fuente proporcionado.

A menos que se indique lo contrario, los nombres de las compañías, organizaciones, productos, personas y eventos mencionados son ficticios. No se pretende indicar, ni debe deducirse ninguna asociación con compañías, organizaciones, productos, personas o eventos reales. Es responsabilidad del usuario el cumplimiento de todas las leyes de derechos de autor aplicables. Sin limitar los derechos del copyright, ninguna parte de este documento puede ser reproducida, almacenada o introducida en ningún sistema de recuperación, transmitida de ninguna forma ni por ningún medio (ya sea electrónico, mecánico, mediante fotocopias o grabaciones) con ningún propósito sin la previa autorización por escrito de Microsoft Corporation.

Microsoft puede ser titular de patentes, solicitudes de patentes, marcas, derechos de autor y otros derechos de propiedad intelectual sobre los contenidos de este documento. El suministro de este documento no le otorga ninguna licencia sobre estas patentes, marcas, derechos de autor u otros derechos de propiedad intelectual, a menos que ello se prevea en un contrato por escrito de licencia de Microsoft.

©1996-2000 Microsoft Corporation. Reservados todos los derechos.

Active Directory, ActiveX, BackOffice, CodeView, Developer Studio, FoxPro, JScript, Microsoft, Microsoft Press, Microsoft SQL Server, MSDN, MS-DOS, Outlook, PivotChart, PivotTable, PowerPoint, Visual Basic, Visual C++, Win32, Windows 2000, Windows y Windows NT son marcas registradas o marcas de Microsoft Corporation en los Estados Unidos y/o otros países.

Otros nombres de productos y compañías mencionados aquí pueden ser marcas comerciales de sus respectivos propietarios.

Versión: 8.00.000